Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Router Wireless, SOHO, Load Balance ed Enterprise
Rispondi
Avatar utente
effeti
Moderatore globale
Messaggi: 1841
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 9 volte
E’ stato ringraziato: 34 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti »

Avviso: aggiornato secondo messaggio e inserita la nuova versione di OpenWrt (19.07.1)



Avatar utente
effeti
Moderatore globale
Messaggi: 1841
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 9 volte
E’ stato ringraziato: 34 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti »

Aggiornato secondo messaggio e inserita la nuova versione di OpenWrt (19.07.2)

Morpheus1988
Messaggi: 4
Iscritto il: 26/07/2019, 21:42

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Morpheus1988 »

Ciao effeti torno dopo un po' di tempo con degli aggiornamenti. Dopo diecimila prove e 1000 smanettamenti sono riuscito a capire parte del problema.
Il fatto che i dispositivi mi andassero cosi lenti in 2.4ghz era dovuto al fatto che mi si collegavano tutti in G e non in N, e per un bug quando ti colleghi in G il RX rate e' cappato a 1Mbit. Con un workaround si sblocca e va a 24Mbit.
Capito che mi stavo collegando in G, smanettando un po' mi sono reso conto che non avevo ma WMM mode attiva. Attivandola ecco che magicamente problema risolto, tutti i dispositivi si sono collegati in N.
Qui arriva la beffa finale, in questa modalita e' tutto instabile, la velocita e' superlativa, ma ci sono cali continui, disconnesioni, pacchetti persi e perfino un riavvio del router ogni tanto.
Leggendo in rete sembrano problemi mai risolti, come se fosse proprio un difetto hardware ma forse sto sbagliando io. Ho la versione 19.07.03 stabile.
Non ricordo se te l'avevo gia chiesto, ma non e'possibile mettere i driver xiaomi o qualche altro driver funzionante ? Comunque hai qualche consiglio?
Mi sta venendo il dubbio che questi problemi potrebbero essere causati da qualche config mia, dopo tutti questi smanettamenti forse ho incasinato qualcosa. Dove trovo un log della rete? Forse leggendolo o postandolo da qualche parte capisco meglio qual e' il problema.
Nel kernel log ho trovato questo ma non credo c' entri qualcosa

Codice: Seleziona tutto

[ 5198.330853] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[ 5198.337643] br-lan: port 2(wlan1) entered blocking state
[ 5198.342958] br-lan: port 2(wlan1) entered forwarding state
[ 5265.786933] device wlan0 left promiscuous mode
[ 5265.791667] br-lan: port 3(wlan0) entered disabled state
[ 5266.569025] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 5266.580835] br-lan: port 3(wlan0) entered blocking state
[ 5266.586171] br-lan: port 3(wlan0) entered disabled state
[ 5266.592137] device wlan0 entered promiscuous mode
[ 5266.597485] br-lan: port 3(wlan0) entered blocking state
[ 5266.602830] br-lan: port 3(wlan0) entered forwarding state
[ 5266.997533] br-lan: port 3(wlan0) entered disabled state
[ 5273.657621] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 5273.664263] br-lan: port 3(wlan0) entered blocking state
[ 5273.669614] br-lan: port 3(wlan0) entered forwarding state
[11784.064910] mtk_soc_eth 1e100000.ethernet eth0: port 2 link down
[13323.646053] device wlan0 left promiscuous mode
[13323.650754] br-lan: port 3(wlan0) entered disabled state
[13325.818185] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[13325.878333] br-lan: port 3(wlan0) entered blocking state
[13325.883909] br-lan: port 3(wlan0) entered disabled state
[13325.889973] device wlan0 entered promiscuous mode
[13332.938831] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[13332.945895] br-lan: port 3(wlan0) entered blocking state
[13332.951215] br-lan: port 3(wlan0) entered forwarding state
Ultima modifica di effeti il 18/06/2020, 19:48, modificato 1 volta in totale.
Motivazione: Tag code

Avatar utente
effeti
Moderatore globale
Messaggi: 1841
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 9 volte
E’ stato ringraziato: 34 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti »

Morpheus1988 ha scritto:
16/06/2020, 23:53
smanettando un po' mi sono reso conto che non avevo ma WMM mode attiva
Ciao, strano... dovrebbe essere attiva di default...
Morpheus1988 ha scritto:
16/06/2020, 23:53
e'possibile mettere i driver xiaomi o qualche altro driver funzionante ?
Gli unici driver funzionanti erano quelli di Nossiac che lavora in Mediatek
https://github.com/Nossiac/mtk-openwrt-feeds
Ora sono inutilizzabili.
Morpheus1988 ha scritto:
16/06/2020, 23:53
Comunque hai qualche consiglio?
Ti consiglio di postare nel forum OpenWrt la tua configurazione wireless.

Codice: Seleziona tutto

cat /etc/config/wireless

Rispondi