Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Router Wireless, SOHO, Load Balance ed Enterprise
Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » 15/09/2018, 21:20

effeti ha scritto:
13/09/2018, 21:34
si sono quelli, comunque se hai solo cambiato indirizzo IP non serve puoi recuperarlo benissimo. Di che colore è il led? Lampeggia?
Dopo l'accensione giallo, poi blu lampeggiante per qualche secondo veloce, poi rallentato e poi sempre blu fissa.
Con led blu fisso collego una porta eth del router direttamente al pc disabilitando sullo stesso le altre reti e impostando la scheda di rete su dhcp.
Effettuo un inconfig /release e poi un ipconfig /renew e ottengo con un ipconfig quanto segue:
Suffisso DNS specifico per connessione: lan
Indirizzo IPv6 . . . . . . . . . . . . . . . . . : fddb:c260:e842::fd0
Indirizzo IPv6 . . . . . . . . . . . . . . . . . : fddb:c260:e842:0:7ce5:a180:a150:c9bc
Indirizzo IPv6 temporaneo. . . . . . . . . . . . : fddb:c260:e842:0:82d:6666:b4bf:c9b0
Indirizzo IPv6 locale rispetto al collegamento . : fe80::7ce5:a180:a150:c9bc%8
Indirizzo IPv4. . . . . . . . . . . . : 192.168.1.232
Subnet mask . . . . . . . . . . . . . : 255.255.255.0
Gateway predefinito . . . . . . . . . : 192.168.1.1

ping 192.168.1.1

Esecuzione di Ping 192.168.1.1 con 32 byte di dati:
Risposta da 192.168.1.1: byte=32 durata=1ms TTL=64
Risposta da 192.168.1.1: byte=32 durata=1ms TTL=64
Risposta da 192.168.1.1: byte=32 durata=1ms TTL=64
Risposta da 192.168.1.1: byte=32 durata=1ms TTL=64

Statistiche Ping per 192.168.1.1:
Pacchetti: Trasmessi = 4, Ricevuti = 4,
Persi = 0 (0% persi),
Tempo approssimativo percorsi andata/ritorno in millisecondi:
Minimo = 1ms, Massimo = 1ms, Medio = 1ms

ping 192.168.2.1

Esecuzione di Ping 192.168.2.1 con 32 byte di dati:
Risposta da 192.168.1.1: Rete di destinazione non raggiungibile.
Risposta da 192.168.1.1: Rete di destinazione non raggiungibile.
Richiesta scaduta.
Risposta da 192.168.1.1: Rete di destinazione non raggiungibile.

Statistiche Ping per 192.168.2.1:
Pacchetti: Trasmessi = 4, Ricevuti = 3,
Persi = 1 (25% persi),


ping 192.168.1.232

Esecuzione di Ping 192.168.1.232 con 32 byte di dati:
Risposta da 192.168.1.232: byte=32 durata<1ms TTL=128
Risposta da 192.168.1.232: byte=32 durata<1ms TTL=128
Risposta da 192.168.1.232: byte=32 durata<1ms TTL=128
Risposta da 192.168.1.232: byte=32 durata<1ms TTL=128

Statistiche Ping per 192.168.1.232:
Pacchetti: Trasmessi = 4, Ricevuti = 4,
Persi = 0 (0% persi),
Tempo approssimativo percorsi andata/ritorno in millisecondi:
Minimo = 0ms, Massimo = 0ms, Medio = 0ms

Con Putty con nessuno dei 3 ip sopra indicati riesco ad ottenere la richiesta di credenziali.

Grazie per la pazienza.
Max



Avatar utente
effeti
Moderatore globale
Messaggi: 1752
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 8 volte
E’ stato ringraziato: 21 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti » 17/09/2018, 10:59

Maxb66 ha scritto:
15/09/2018, 21:20
Dopo l'accensione giallo, poi blu lampeggiante per qualche secondo veloce, poi rallentato e poi sempre blu fissa.
Perfetto, quindi puoi recuperarlo senza seriale.
Maxb66 ha scritto:
15/09/2018, 21:20
Gateway predefinito . . . . . . . . . : 192.168.1.1
Quindi non ha cambiato l'IP
Maxb66 ha scritto:
15/09/2018, 21:20
Con Putty con nessuno dei 3 ip sopra indicati riesco ad ottenere la richiesta di credenziali.
Devi usare 192.168.1.1 e protocollo SSH non telnet.

Puoi usare anche la modalità failsafe:
effeti ha scritto:
13/09/2018, 10:36
Se neanche così riesci usa la modalità failsafe, quando il router si stà avviando e il led inizia a lampeggiare premi il tasto reset per un secondo, il led inizierà a lampeggiare molto velocemente. Configuri il pc con IP statico 192.168.1.10 e ti colleghi a 192.168.1.1 usando putty protocollo ssh

Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » 18/09/2018, 19:46

effeti ha scritto:
13/09/2018, 10:36
Se neanche così riesci usa la modalità failsafe, quando il router si stà avviando e il led inizia a lampeggiare premi il tasto reset per un secondo, il led inizierà a lampeggiare molto velocemente. Configuri il pc con IP statico 192.168.1.10 e ti colleghi a 192.168.1.1 usando putty protocollo ssh
Urra! Così sono entrato nel router ora mi ha dato la seguente videata:

Codice: Seleziona tutto

login as: root


BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.1, r7258-5eb055306f
 -----------------------------------------------------
================= FAILSAFE MODE active ================
special commands:
* firstboot          reset settings to factory defaults
* mount_root     mount root-partition with config files

after mount_root:
* passwd                         change root's password
* /etc/config               directory with config files

for more help see:
https://openwrt.org/docs/guide-user/troubleshooting/
- failsafe_and_factory_reset
- root_password_reset
=======================================================

root@(none):~#
Ho provato a procedere questo modo cercando di seguire quanto indicato in https://openwrt.org/docs/guide-user/tro ... tory_reset:

Codice: Seleziona tutto

root@(none):~# mount_root
loading kmods from internal overlay
switching to ubifs overlay
root@(none):/rom/root#

Codice: Seleziona tutto

root@(none):/rom/root# passwd
Changing password for root
New password:
Retype password:
passwd: password for root changed by root

Codice: Seleziona tutto

root@(none):/rom/root# umount /overlay && firstboot && reboot
This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
/dev/ubi0_1 is not mounted
/dev/ubi0_1 will be erased on next mount
writing /dev/ubi0_1 failed: Bad file descriptor
root@(none):/rom/root# mount_root
loading kmods from internal overlay
failed to mkdir /tmp/overlay: File exists
overlay filesystem has not been fully initialized yet
switching to ubifs overlay
switching to ubifs failed - fallback to ramoverlay
root@(none):/rom/rom/root# umount /overlay && first
umount: can't unmount /overlay: Invalid argument
root@(none):/rom/rom/root#
Cercando nel sito OpenWrt ho trovato la pagina https://wiki.openwrt.org/doc/howto/generic.failsafe ed ho cercato di seguire le indicazioni con il seguente risultato dopo aver spento il router e riacceso in failsafe mode :

Codice: Seleziona tutto

login as: root


BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.1, r7258-5eb055306f
 -----------------------------------------------------
================= FAILSAFE MODE active ================
special commands:
* firstboot          reset settings to factory defaults
* mount_root     mount root-partition with config files

after mount_root:
* passwd                         change root's password
* /etc/config               directory with config files

for more help see:
https://openwrt.org/docs/guide-user/troubleshooting/
- failsafe_and_factory_reset
- root_password_reset
=======================================================

root@(none):~# mount_root
loading kmods from internal overlay
switching to ubifs overlay
root@(none):/rom/root# get network.lan.ipaddr
-ash: get: not found
root@(none):/rom/root# uci get network.lan.ipaddr
192.168.1.1
root@(none):/rom/root# firstboot
This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
/dev/ubi0_1 is mounted as /overlay, only erasing files
root@(none):/rom/root# rm -r /overlay/*
root@(none):/rom/root# mtd -r erase rootfs_data
Could not open mtd device: rootfs_data
Could not open mtd device: rootfs_data
root@(none):/rom/root#
Siccome mi sembra che sia arrivato ad un punto morto riusciresti ad indicarmi i comandi corretti per riprovare a ripartire ?

Spiego la mia attuale configurazione e necessità:
  • modem TIM Fibra con gateway 192.168.1.1 posto al piano terra
  • il router è posto al secondo piano ed è connesso ora via lan al modem attraverso una powerline
  • vorrei che il router Xiaomi lavorasse con una classe differente ad es. 192.168.2.1
  • vorrei gestire sul router una vpn con protocollo openvpn ed utilizzo wifi
PS: provando a rispegnere e riaccendere il router se lascio fare il reboot normale dopo aver ottenuto la luce blu fissa non riesco ad entrare ne via putty ne via web. Ripetendo il reset con la pressione del tasto (failsafe) entro da putty e mi si ripresenta quanto indicato nella prima videata.

Un sentito ringraziamento.
Max

Avatar utente
effeti
Moderatore globale
Messaggi: 1752
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 8 volte
E’ stato ringraziato: 21 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti » ieri, 9:00

Molto strana come cosa... cambiamo l'ip a mano da failsafe.
Una volta connesso di nuovo al router scrivi

Codice: Seleziona tutto

mount_root
Ti sposti nella directory con la configurazione

Codice: Seleziona tutto

cd /etc/config
e con l'editor VI modifichi il file network

Codice: Seleziona tutto

vi network
I comandi sono abbastanza semplici, devi modificare option ipaddr nella sezione config interface 'lan', con le frecce vai sopra la riga che ti interessa e premi a per attivare le modifiche. Una volta terminato salvi ed esci scrivendo :wq! e riavvi con reboot.

Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » ieri, 9:19

Ho provato ma mi sembra che il file network sia completamente vuoto:

Codice: Seleziona tutto

login as: root


BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.1, r7258-5eb055306f
 -----------------------------------------------------
================= FAILSAFE MODE active ================
special commands:
* firstboot          reset settings to factory defaults
* mount_root     mount root-partition with config files

after mount_root:
* passwd                         change root's password
* /etc/config               directory with config files

for more help see:
https://openwrt.org/docs/guide-user/troubleshooting/
- failsafe_and_factory_reset
- root_password_reset
=======================================================

root@(none):~# mount_root
loading kmods from internal overlay
overlay filesystem has not been fully initialized yet
switching to ubifs overlay
root@(none):/rom/root# cd /etc/config
root@(none):/etc/config# vi network
root@(none):/etc/config# ls
ddns             luci             pptpd            uhttpd
dhcp             minidlna         rpcd             upnpd
dropbear         openvpn          samba            wifi_schedule
firewall         openvpn_recipes  sqm
hd-idle          p910nd           ucitrack
root@(none):/etc/config#
Qui non si vede ma dopo il comando vi network mi ha aperto un file con solo delle righe in cui era presente la ~ (tilde), per cui ho digitato :q per uscire.

Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » ieri, 10:13

OK sono riuscito a ricreare il file network nel seguente modo:

Codice: Seleziona tutto

  root@(none):/# firstboot
 root@(none):/# reboot -f
ed ho modificato l'ip:

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:1201:4db3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '40:31:3c:03:e5:50'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

root@OpenWrt:/etc/config#
modificando le impostazioni della scheda di rete del pc su IP/Gateway 192.168.2.10/192.168.2.1 riesco ad accedere a LuCI.
Credo però che per accedere a internet dal dispositivo debba anche modificare anche qualche altro parametro (WAN?)

Avatar utente
effeti
Moderatore globale
Messaggi: 1752
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 8 volte
E’ stato ringraziato: 21 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti » ieri, 10:36

Maxb66 ha scritto:
ieri, 10:13
Credo però che per accedere a internet dal dispositivo debba anche modificare anche qualche altro parametro (WAN?)
Dipende da cosa hai collegato nella WAN, il router del tuo operatore? Un modem/router in bridge?

Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » ieri, 12:18

Ora funziona, anche se non so se siano le impostazioni ottimali.
Definendo router (192.168.2.1) lo Xiaomi con OpenWRT e modem (192.168.1.1) il modem/router che fa da gateway per l'accesso ad internet:
  • ho connesso la porta WAN del router al modem (via powerline)
  • ho configurato l'interfaccia WAN con indirizzo statico a 192.168.1.3
  • attivato il wifi del router
  • settato il Country code della wlan su Italy
  • settato l'encryption su WPA2-PSK, Cypher: Force CCMP (AES)

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:1201:4db3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '40:31:3c:03:e5:50'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

root@OpenWrt:/etc/config#
Va bene o è meglio modificare qualcosa?

Avatar utente
effeti
Moderatore globale
Messaggi: 1752
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 8 volte
E’ stato ringraziato: 21 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti » ieri, 14:59

Va benissimo 😉

Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » ieri, 16:44

effeti ha scritto:
ieri, 14:59
Va benissimo 😉
Grazie, ma in realtà riuscivo a connettermi ad internet unicamente dal pc nel quale avevo impostato la scheda lan con gateway 192.168.2.1, anche se comunque questo si connetteva al router in wireless in quanto avevo staccato il cavo lan che collegava pc a router :?: .
Dagli altri dispositivi mi dava "internet non disponibile".
Questa era la configurazione:
file NETWORK:

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:1201:4db3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '40:31:3c:03:e5:50'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.4'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

root@OpenWrt:/etc/config#
file DHCP:

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option start '100'
        option limit '150'
        option leasetime '12h'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:/etc/config#
Modificando il protocollo della WAN da Static a DHCP Client anche gli altri dispositivi si collegano ma, ovviamente sul modem, il router prende un indirizzo dinamico e non 192.168.1.4 (ha preso 192.168.1.221). In questo caso i file hanno il seguente contenuto:

file NETWORK:

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:1201:4db3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '40:31:3c:03:e5:50'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'
file DHCP:

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option start '100'
        option limit '150'
        option leasetime '12h'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:/etc/config#
Penso di sbagliare da qualche parte ma non riesco a capire dove.

Avatar utente
effeti
Moderatore globale
Messaggi: 1752
Iscritto il: 02/06/2010, 15:32
Ha ringraziato: 8 volte
E’ stato ringraziato: 21 volte

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da effeti » ieri, 21:31

Maxb66 ha scritto:
ieri, 16:44
Dagli altri dispositivi mi dava "internet non disponibile".
Non hai aggiunto il server DNS
Maxb66 ha scritto:
ieri, 16:44
Modificando il protocollo della WAN da Static a DHCP Client anche gli altri dispositivi si collegano ma, ovviamente sul modem,
Corretto, mi dici esattamente come vorresti usare il router 3G?
Vuoi usarlo al posto del router wireless (che modello?) 192.168.1.1 fornito dal gestore ?

Maxb66
Messaggi: 9
Iscritto il: 09/09/2018, 18:04

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da Maxb66 » ieri, 22:39

effeti ha scritto:
ieri, 21:31
Non hai aggiunto il server DNS
Ha ok ora ho riportato la WAN con IP statico ed inserito i DNS google, mi sembra che anche gli altri client si colleghino:

Codice: Seleziona tutto

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc6:1201:4db3::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '40:31:3c:03:e5:50'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.4'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8 8.8.4.4'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

root@OpenWrt:/etc/config#
effeti ha scritto:
ieri, 21:31
Corretto, mi dici esattamente come vorresti usare il router 3G?
Vuoi usarlo al posto del router wireless (che modello?) 192.168.1.1 fornito dal gestore ?
Il modem/router che fa da gataway per l'accesso alla FTTC TIM è il TIM HUB - TECHNICOLOR DGA 4132 (AGTHP).
Il modem si trova al piano terra e al secondo piano ho il 3G connesso al modem attraverso una powerline.
Il 3G mi servirebbe per due cose:
  • dare copertura wifi al primo piano e al secondo piano
  • installare sul 3G una VPN
In pratica sia il modem che il 3G forniranno la rete wifi, per dare copertura a tutta la casa, in più vorrei, attivare, anche temporaneamente, sul 3G una VPN. Ho già un abbonamento ad una servizio ma che ho sempre utilizzato direttamente da client e vorrei invece mediante OpenWRT installarla sul 3G con OpenVPN. In relazione a questo ho trovato una guida a questo link che non ho ancora sperimentato perchè prima volevo correttamente settare modem e 3G.
Mi sembra di capire che bisogna verificare e settare conseguentemente quali servizi lasciare al modem e quali al router (3G).

fracd
Messaggi: 1
Iscritto il: 16/09/2018, 10:40

Re: Xiaomi Mi Router 3G WiFi b/g/n/ac 1200Mbps, Gigabit WAN/LAN, USB 3.0

Messaggio da fracd » oggi, 13:04

Ragazzi su questo firmware c'è l'opzione"no VPN no internet"? Ti permette di avere Internet solo se la VPN è collegata

Rispondi